Gallery
Excel - Power Query - Power Pivot - VBA
Share
Explore
Temps 3 | Calculer

icon picker
Fonctions de texte

Les fonctions Excel pour extraire du texte de cellules

GAUCHE et DROITE

Retourne les X caractères de gauche / droite d’une cellule.
GAUCHE(texte;[no_car])
DROITE(texte;[no_car])

Exemple

image.png
=GAUCHE([@CodePostal];2)
[@CodePostal] : la cellule [@CodePostal]
2 : 2 caractères à afficher, en partant de la gauche.
La syntaxe est identique pour la fonction DROITE.

STXT

Affiche X premiers caractères d’une cellule, en partant d’une position Y
STXT(texte;no_départ;no_car)

Exemple

image.png
On souhaite extraire le code entre les deux tirets :
=STXT([@Code];4;3)
[@Code] : la cellule contenant la valeur dont on veut extraire des caractères.
4 : la position du 1er caractère à retourner, en partant de la gauche, ici donc 4.
3 : le nombre de caractères à retourner, ici donc 3.
Si vous partez de la position 1, autant utiliser la fonction GAUCHE.

TROUVE

Affiche la position d’un caractère dans une cellule (en partant de la gauche).
TROUVE(texte_cherché;texte)

Exemple

image.png
=TROUVE("-";[@Code])
Composé avec les arguments suivants :
"-": le tiret qu’on recherche
[@Code] : La colonne où l’on effectue la recherche

TEXTE

Formate une cellule.
TEXTE(texte;format_texte)

Exemple

On veut afficher le mois d’une date sous forme de texte (janvier…) :
image.png
Dans la colonne Mois, on a donc la formule :
=TEXTE([@Date];"mmmm")
Composé avec les arguments suivants :
[@Date] : la cellule [@Date]
"mmmm": le format pour afficher un mois en lettre (4 fois la lettre mmmm)
Autres formats possibles
0
Code
Signification
1
j
Jour du mois sans 0
2
jj
Jour du mois avec 0
3
jjj
Jour de la semaine abrégé
4
jjjj
Jour de la semaine complet
5
m
Mois sans 0
6
mm
Mois avec 0
7
mmm
Mois abrégé
8
mmmm
Mois long
9
aa
Année sans le siècle
10
aaaa
Année avec le siècle
There are no rows in this table
10
Count

CNUM

Converti une valeur texte en numérique.
CNUM(texte)

Exemple

On souhaite extraire les 6 premiers caractères (fonction GAUCHE) de la colonne Client, puis convertir ces 6 caractères en numérique :
=CNUM(GAUCHE([@Client];6))

Concaténer

La concaténation consiste à regrouper du texte. Par exemple, "mai" et "son" donnerai "maison". Il existe 3 façons de concaténer :

Méthode 1

Utiliser la fonction CONCATENER. Cette fonction peut être supprimé dans les futurs versions d’Excel. Par exemple :
=CONCATENER(A2;A3)
Permet de regrouper dans une même cellule le contenu des cellules A2 et A3.

Méthode 2

[Conseillé] Utiliser le caractère & (esperluette) - c’est la touche 1 en minuscule.
=A2 & A3
Vous pouvez mettre un espace de part et d’autre de l’esperluette, mais ce n’est pas obligatoire ; cela facilite la lecture de la formule pour son créateur.
Pour intercaler un espace :
=A2 & " " & A3

Méthode 3 [2016]

Depuis la version 2016 d’Excel, vous pouvez utiliser la fonction CONCAT, qui prend comme unique argument une plage de cellule (et non une liste de cellules séparées par des ; comme avec CONCATENER)
=CONCAT(A2:E2)
Regroupe, dans une même cellule, toutes les cellules comprises entre la cellule A2 et la cellule D2.

Share
 
Want to print your doc?
This is not the way.
Try clicking the ⋯ next to your doc name or using a keyboard shortcut (
CtrlP
) instead.