as advised by Coda.I was able to validate the examples below also work with CurrentValue. I think WithName() is better for two reasons—1) it’s easier to read/remember the variable reference deep inside the formula 2) if you build on top of these examples and end up having an inner and outer CurrentValue, you won’t have to refactor the whole thing
Get the unique projects that an organization is working on
table has a list of employees. To get the list of projects that an organization is working on, we have to pull out the projects that each employee of the organization is working on. The formula to accomplish that produces a list of lists (a list of the list of projects for each employee).
, we’ve extended a view of the Organizations table further to show a distribution of employees by the number of projects they are working on. The formula to accomplish that lets us see who is unassigned (0 projects), who might be on too many projects (5+), and everything in between.
To accomplish this, we swap the ForEach() with Filter() and update the expression to a boolean that shows the employees with count of zero project assignments. Then we repeat that formula in each column to match the criteria we want—1 project, 2 projects, 3 projects, 4 projects, 5+ projects.